DBに同じ内容のデータが連続して登録される場合
最終更新日:2025年06月18日
DBに連続したタイミングで同じデータが登録される場合、いくつかの原因が考えられます。
原因
1.フォームの「送信ボタン」をダブルクリックしている場合
2.フォームのサンキューページにてリロードを行った場合
3.APIを連続して実行した場合
4.DBオペレーションにて連続してデータを登録した場合
※上記の原因は一例ですが「何を用いて登録されたか」は、DBオペレーションの「登録元」のフィールドからご確認いただくことが可能です。
また、上記原因に合致する場合にはフォームの設定やDBの設定で防ぐことができます。下記の設定をお試しください。
回避策
フォームの「連続投稿の禁止」機能
フォームのセキュリティ設定ページにて、「連続投稿の禁止」を設定いただくことで
設定した時間内に同一IPからの連続した投稿を防止することが可能です。
※原因1に対して有効となります。
DBの「フィールド属性」機能
DBに設定されているフィールドの属性設定でフィールドを「重複不可」にしていただくことで
DB上に同じ内容を含むデータを登録することが不可となります。
※DB内の一部のフィールドを重複不可に設定することで、同一内容の投稿を制限可能です。
※上記4つの原因全てに有効となります。
※連続した同一内容の投稿以外にも、重複内容の投稿を防ぐことが可能です。
その他
スパイラルver1.14.6リリース以前は、原因2への対策としてフォームのセキュリティ設定ページにて「不正経路からの登録防止」を「制限する」に設定することで対応が可能でした。
ver1.14.6リリース以降は「制限する」を選択した際に、よりセキュアな選択肢として「外部サイトからの登録防止」が選べるようになりましたが、「外部サイトからの登録防止」については、原因2の回避を目的とした機能ではないため、原因2に対しての回避策はフォームの「連続投稿の禁止」機能もしくはDBの「フィールド属性」機能による対応を推奨いたします。
※「外部サイトからの登録防止」についての詳細はこちらをご確認ください。